summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Widen <andreas@harmonicflow.org>2019-07-18 15:48:58 +0200
committerAndreas Widen <andreas@harmonicflow.org>2019-07-18 15:48:58 +0200
commiteb2e3f8bfb7289422a8a6c9aacc8101ce9edef32 (patch)
treea73574a79bc84282576c2b0777e352fd23d6d3fa
parent3349f383376dc9f55ff10ae0ddc0016fac1da70e (diff)
downloadHarmonicFlowOrgWeb-eb2e3f8bfb7289422a8a6c9aacc8101ce9edef32.tar.xz
HarmonicFlowOrgWeb-eb2e3f8bfb7289422a8a6c9aacc8101ce9edef32.zip
Updated about page for libhffwk.
Signed-off-by: Andreas Widen <andreas@harmonicflow.org>
-rwxr-xr-xharmonicflow-framework/about.php23
1 files changed, 7 insertions, 16 deletions
diff --git a/harmonicflow-framework/about.php b/harmonicflow-framework/about.php
index a7d4198..676744d 100755
--- a/harmonicflow-framework/about.php
+++ b/harmonicflow-framework/about.php
@@ -20,9 +20,9 @@
engine framework written in C++.
</p>
<p>
- Harmonic Flow Framework currently supports Windows, Mac OS, GNU/Linux,
- iOS and Android platforms, aiming to be easy-to-use, fast and easily
- extendable to other platforms if needed.
+ Harmonic Flow Framework currently supports Windows and GNU/Linux
+ platforms, aiming to be easy-to-use, and easily extendable to
+ other platforms if needed.
</p>
<p>
Check out these <a href="/blog/tags/libhffwk/">tagged blog
@@ -35,8 +35,8 @@
<ul>
<li>Modern shader driven rendering pipeline.</li>
<li>Vertex and Fragment (Pixel) shader support.</li>
- <li>Hardware accelerated rendering through OpenGL, OpenGL ES and Direct3D9.</li>
- <li>C++11 support enabled.</li>
+ <li>Hardware accelerated rendering through OpenGL and Direct3D9.</li>
+ <li>C++14 support enabled.</li>
<li>Comes with powerful math library glm.</li>
<li>Batch rendering.</li>
<li>Flexible Geometry interface for complete control over the
@@ -73,26 +73,17 @@
<ul>
<li>Windows 7 or newer.</li>
<li>GNU/Linux such as Debian, Ubuntu and more.</li>
- <li>Mac OS X 10.9 or newer (Intel only).</li>
- <li>iOS 10 or newer (64 bit only).</li>
- <li>Android 4.4.2 or newer (API level 19).</li>
- <li>OpenGL 2.1 or newer for desktop (Windows, Mac OS and
- GNU/Linux).</li>
- <li>OpenGL ES 2.0 or newer for mobile (iOS and Android).</li>
+ <li>OpenGL 2.1 or newer for desktop (Windows and GNU/Linux).</li>
<li>DirectX 9.0c or newer for desktop Windows.</li>
</ul>
<br>
- A compiler with C++11 support is required to build
+ A compiler with C++14 support is required to build
libhffwk.<br><br>
libhffwk comes with Autotools and CMake toolchain support to
keep building flexible using Makefiles or projects for your
preferred IDE.<br><br>
- On Mac OS 'XCode command line tools' can be installed to be able
- to use the supplied build scripts
- (build_scripts/macosx*.sh).<br><br>
-
On Windows MSYS2 + mingw toolchain can be installed to be able to
use the supplied build scripts
(build_scripts/windows*.sh).<br><br>